Install on Fedora Core

From Geoqo
Revision as of 22:25, 5 October 2007 by Yamar (Talk | contribs)
Jump to: navigation, search

Installing the prerequisites

Run:

 ./check-prerequisites.pl
and follow the instructions. You will likely need to re-run it multiple times.

Some packages handled by yum/RPMs

On Fedora Core 6, these packages may be useful: sqlite2, perl-DBD-SQLite2, perl-XML-Simple, perl-Class-DBI, perl-IO-String, and perl-XML-Parser. To install all of them run (as root):

 yum install sqlite2 perl-DBD-SQLite2 perl-XML-Simple perl-Class-DBI perl-XML-Parser perl-IO-String

If you want to use the GUI support run both:

 yum install perl-Gtk2 perl-GD
 perl -MCPAN -e "install QWizard"

TODO: discuss other RPMs that solve more prereqs?

Installing GeoQO itself

Run the following commands:

 perl Makefile.PL
 make

And as root run:

 make install
Personal tools